Cохранение значений реквизитов формы в файл (1с 8.1)

Озадачился сохранением реквизитов формы в файл, для общего использования одновременно несколькими пользователями. SuperMario (http://www.forum.mista.ru/users.php?id=10887) подал идею.


Код следующий:
Процедура СохранитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Если ЗначениеЗаполнено(ЭлементФормы.Данные) Тогда
ЗнВСтр = ЗначениеВСтрокуВнутр(ЭлементФормы.Значение);
СтруктураЭлементов.Вставить(ЭлементФормы.Имя, ЗнВСтр);
КонецЕсли;
КонецЦикла;
ЗначениеВФайл(”O:\Load Upload (1c data authomat exchange)\Buh\PoFirmam.sav”, СтруктураЭлементов);
КонецПроцедуры

Процедура ВосстановитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
СтруктураЭлементов = ЗначениеИзФайла(”O:\Load Upload (1c data authomat exchange)\Buh\PoFirmam.sav”);
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Попытка
ЭлементФормы.Значение = ЗначениеИзСтрокиВнутр(СтруктураЭлементов[ЭлементФормы.Имя])
Исключение
КонецПопытки;
КонецЦикла;
КонецПроцедуры